This is the same problem that's well known in Ubuntu 14.04 and distributions that are based on it. See this other forum post.

The problem is that on a new installation of Deepin 2014 or an upgrade to Deepin 2014 in VirtualBox, the maximum screen resolution you get is 640x480. This screenshot shows how that looks.


And the solution is the same: Install xdiagnose and enable all the options under the Debug section. Use Deepin Store to install xdiagnose, then enable those options.


After the operation on XDiagnose, reboot the computer. Login, then enable the higher resolution from the Control Center.


You should now have a desktop with the right screen resolution.